Intermittent AWS Integration performance degradation

Incident Report for JupiterOne

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:42 EDT

Update

Dashboard and Integrations page functionality has been restored. We will continue to monitor.
Posted Oct 20, 2025 - 16:07 EDT

Update

JupiterOne is experiencing degradation in dashboards, the integrations page (in the web app), and a small subset of rule evaluations (ones that validate integration instances) related to the ongoing AWS outage (https://health.aws.amazon.com/health/status). Integration jobs appear to be processing as normal, though may see intermittent impacts due to AWS API degradation. We are working to resolve the impacted services.
Posted Oct 20, 2025 - 12:18 EDT

Update

JupiterOne is experiencing degradation in dashboards, the integrations page (in the web app), and a small subset of rule evaluations (ones that validate integration instances) related to the ongoing AWS outage (https://health.aws.amazon.com/health/status). Integration jobs appear to be processing as normal, though may see intermittent impacts due to AWS API degradation. We are working to resolve the impacted services.
Posted Oct 20, 2025 - 10:48 EDT

Update

JupiterOne is experiencing degradation in dashboards, the integrations page (in the web app), and a small subset of rule evaluations (ones that validate integration instances) related to the ongoing AWS outage (https://health.aws.amazon.com/health/status). Integration jobs appear to be processing as normal, though may see intermittent impacts due to AWS API degradation. We are working to resolve the impacted services.
Posted Oct 20, 2025 - 09:57 EDT

Monitoring

JupiterOne is experiencing AWS Integrations intermittent performance degradation and potential availability issues due to an ongoing AWS infrastructure outage (https://health.aws.amazon.com/health/status). This may impact any rules that are tied to our integrations. We are actively monitoring the situation and working with AWS to resolve the underlying issue.
Posted Oct 20, 2025 - 09:53 EDT

Update

JupiterOne is experiencing AWS Integrations intermittent performance degradation and potential availability issues due to an ongoing AWS infrastructure outage (https://health.aws.amazon.com/health/status). This may impact any rules that are tied to our integrations. We are actively monitoring the situation and working with AWS to resolve the underlying issue.
Posted Oct 20, 2025 - 09:03 EDT

Investigating

JupiterOne is experiencing AWS Integrations intermittent performance degradation and potential availability issues due to an ongoing AWS infrastructure outage (https://health.aws.amazon.com/health/status). We are actively monitoring the situation and working with AWS to resolve the underlying issue.
Posted Oct 20, 2025 - 09:02 EDT
This incident affected: Integrations (AWS) and Core Platform (App, Integration jobs).